Updox live chat support currently unavailable

Incident Report for Updox

Resolved

This incident has been resolved.
Updox Live-Chat Support is available by visiting Updox.com/support or click the need help button from your Updox inbox.
Posted May 29, 2024 - 13:30 EDT

Identified

Updox Live-Chat Support is currently unavailable. To reach support, please email support@updox.com. A support case will be created and we will reach out to you as quickly as possible.
We apologize for any inconvenience this causes and appreciate your patience while we wait for our Live-Chat Support system to be restored.
Posted May 29, 2024 - 11:24 EDT

Investigating

We are currently investigating this issue.
Posted May 29, 2024 - 11:22 EDT

Update

We are continuing to work on a fix for this issue.
Posted May 29, 2024 - 11:22 EDT

Identified

Updox Live-Chat Support is currently unavailable. To reach support, please email support@updox.com. A support case will be created and we will reach out to you as quickly as possible.
We apologize for any inconvenience this causes and appreciate your patience while we wait for our Live-Chat Support system to be restored.
Posted May 29, 2024 - 11:17 EDT
This incident affected: Updox.