Live Chat System Outage

Incident Report for Updox

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 14:18 EDT

Identified

Our Live Chat System is currently unavailable. To contact Support, please email support@updox.com or visit https://www.updox.com/support/ and fill out the form to open a case.
The Updox application and APIs are not affected.
Posted Oct 20, 2025 - 12:52 EDT