Release of Information
Incident Report for Updox
Resolved
This incident has been resolved.
Posted Nov 10, 2023 - 15:55 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 10, 2023 - 15:12 EST
Identified
Release of Information is currently unavailable. If you attempt to print and ‘add to release of information’, you will receive an error message. Additionally, if you attempt to create a new ROI request, you will receive an error message.
We sincerely apologize for any inconvenience this causes to your business and will provide an update once this functionality is restored.
Posted Nov 10, 2023 - 11:47 EST
This incident affected: Updox.