Outbound Fax Delay

Incident Report for Updox

Resolved

A fix has been implemented by our Fax Telecommunications provider. They do expect some delays to continue until they have cleared the queue of pending faxes.
We sincerely apologize for any impact this caused to you and your business.
If you require further assistance, please visit https://www.updox.com/support/.
Posted Sep 18, 2023 - 18:31 EDT

Identified

One of our Fax Telecommunication providers is experiencing delays on outbound faxes. Some outbound faxes may be delayed in reaching the recipients.

They are addressing the issue and will keep us updated on their efforts. We apologize for any inconvenience this causes to your business and we will keep you updated on their progress.
Posted Sep 18, 2023 - 15:16 EDT
This incident affected: Fax.