Updox Inbox Unavailable

Incident Report for Updox

Resolved

This incident has been resolved.
Posted Oct 30, 2024 - 12:46 EDT

Monitoring

We have implemented a fix for the disruption in service and the issue is resolved. All systems are operational at this time. We will continue to monitor.
Posted Oct 30, 2024 - 12:39 EDT

Identified

Updox is experiencing a disruption in service. Users may not be able to access the application. We are investigating the issue and will post updates every 30 minutes.
Posted Oct 30, 2024 - 12:11 EDT
This incident affected: Updox.