Updox Support Ticketing System - Unable to reply by email
Incident Report for Updox
Resolved
This incident has been resolved.
Posted Mar 20, 2024 - 13:03 EDT
Identified
We are currently unable to reply to tickets submitted to our support@updox.com address. This is also affecting partnersupport@updox.com. We are receiving emails and working tickets, however we are unable to reply by email at this time. Our Business Operations team is working to restore the functionality. We will reply to submitted tickets once functionality is restored.
Posted Mar 20, 2024 - 11:49 EDT