Updox Inbox Unavailable
Incident Report for Updox
Resolved
We have implemented a fix for the disruption in service and the issue is resolved. All systems are operational at this time.
Posted Oct 31, 2024 - 16:35 EDT
Identified
Updox is experiencing a disruption in service. Users may not be able to access the Updox inbox. We are investigating the issue and will post updates every 30 minutes.
Posted Oct 31, 2024 - 15:57 EDT
This incident affected: Updox.