Documents Unavailable

Incident Report for Updox

Resolved

This incident has been resolved.
Posted Nov 10, 2023 - 15:54 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 10, 2023 - 15:13 EST

Identified

We are aware some documents are temporarily unavailable. Our technical operations team is working to restore these documents as quickly as possible.
We sincerely apologize for any inconvenience this causes to your business and will keep you updated on our progress.
Posted Nov 10, 2023 - 11:46 EST
This incident affected: Updox.