System Degradation

Incident Report for Updox

Resolved

This incident has been resolved.
Posted Apr 24, 2025 - 11:46 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 24, 2025 - 11:35 EDT

Identified

Updox is experiencing a disruption in service. The inbox may be unavailable. We are investigating the issue and will post updates every 30 minutes. We appreciate your patience as we work to restore functionality.
Posted Apr 24, 2025 - 11:28 EDT
This incident affected: Updox.