System Performance
Incident Report for Updox
Resolved
This incident has been resolved.
Posted Sep 29, 2021 - 08:46 EDT
Monitoring
A fix has been implemented and we are monitoring the results.

If you do experience any further trouble, please contact support by visiting Updox.com/support and click on the chat icon in the lower right corner to speak with a live-chat representative.
Posted Sep 28, 2021 - 16:03 EDT
Investigating
Our Engineering team is currently investigating reports of system slowness and error messages in the Updox Inbox. We apologize for any impact this causes to your business and will keep you updated on our progress.
Posted Sep 28, 2021 - 15:42 EDT
This incident affected: Updox and Patient Portal.