Images Not Loading
Incident Report for Updox
Resolved
This incident has been resolved.

If you are still having trouble, please contact Support by visiting Updox.com/support and click on the blue icon in the lower right corner to chat with a live-chat representative.
Posted Jan 11, 2022 - 08:27 EST
Investigating
We are currently experiencing latency and document images not loading in the Updox inbox. Users may also experience trouble logging in. Our Engineering Team is aware and currently investigating the issue. We apologize for any impact this causes to your business and will keep you updated on our progress.
Posted Jan 11, 2022 - 08:15 EST
This incident affected: Updox.