General Slowness / Login Issues
Incident Report for Updox
Resolved
This incident has been resolved.
Posted Jun 07, 2021 - 13:05 EDT
Monitoring
Our Team has resolved the system slowness and login issues experienced earlier this morning and you should now be able to access Updox successfully. If you are still having trouble or have any follow up questions, please reach out.

Create new support cases by visiting https://updox.com/support and fill out our Contact Support form. For immediate assistance, use our Live Chat option in the lower right corner.
Posted Jun 07, 2021 - 10:35 EDT
Investigating
We are currently experiencing an issue with slowness and login issues. (Item preview pages not visible or delayed load time). Our Engineering Team is working on the issue. We apologize for any impact this causes to your business and will keep you updated on our progress.
Posted Jun 07, 2021 - 09:18 EDT
This incident affected: Updox.